Office 365 / mettez à jour Sharepoint Designer 2010 vers 2013 puis convertissez vos conditions en anglais

Publié le Mis à jour le

Bonjour,

Après un jolie mail client (pas énervé du tout) qui m’indique que les mails d’approbation customisé avec Sharepoint Designer  2010 sur leur site Office 365 ne sont plus envoyés, je me connecte avec mon designer 2010 préféré qui m’indique le message suivant :

“Microsoft Sharepoint Designer cannot be used to edit web sites on servers different from Microsoft Sharepoint Server 2010/ To edit these sites, you need to use the same version of Sharepoint Designer wich matches the version of Microsoft Sharepoint Server.”

image

Pas de panique, il faut télécharger Sharepoint Designer 2013 ici : http://www.microsoft.com/fr-fr/download/details.aspx?id=35491

image

Erreur de ma part, j’ai téléchargé le 64 bits, Microsoft Office Sharepoint Designer doit être dans la même version que mon office, à savoir 32 bits :

image

Je télécharge donc en 32 bits…Clignement d'œil et (petite astuce) renomme tout de suite le fichier en sharepointdesigner2013FR_32bit.exe, car d’origine le nom est générique et ne précise pas la version et la langue.

A ce sujet je vous préconise de ne pas faire comme moi, et de bien installer la version en 64 bits, car ceci peut poser des problèmes dans le cas d’une utilisation de BCS avec des ALIAS SQL.

Installation de Sharepoint designer 2013

image

image

imageimage

image

On est en 2013 ! que diable :

image

Lancement de Sharepoint Designer 2013

Après un redémarrage, il suffit de lancer le bon Sharepoint Designer : 2013

image

Je choisi ceci :

image

Un superbe bandeau s’ouvre, me présentant plusieurs infos :

imageimageimageimage

Bonne nouvelle, il reconnait tous mes anciens sites ouvert avec Sharepoint Designer 2010:

image

Après 3 fenêtres me demandant mon login, puis mon mot de passe (??), le site est bien accessible :

image

Correction du problème

Je regarde mes flux de travaille, tout semble correcte :

image

J’ai paramétré entre autre un workflow envoyant un mail lorsqu’un document est approuvé

Sauf qu’en regardant de plus prêt, dans mon historique, je renvoie la valeur de l’état du document, celui ci semble passé en anglais [0;#Approved] :

image

alors que dans mon workflow, comme configuré depuis quelques mois j’ai bien en français [0;#Approuvé]:

image

Je tente donc de stocker la valeur de l’état du document dans une variable nommé [EtatDocument]…

image

..puis je remplace ma condition d’envoie de mail par la valeur en Anglais, en saisissant explicitement 0;Approved

image

C’est ca ! mon mail est parti.

Bilan

Si vous êtes Sous Office 365, et que vous avez des conditions en français dans vos Workflow Designer (maintenant Sharepoint Designer 2013), convertissez vos conditions en anglais en passant par des variables.

Je vous laisse, j’ai quelques coups de fil à passer Clignement d'œil

Publicités

Laissez un commentaire

Choisissez une méthode de connexion pour poster votre commentaire:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion /  Changer )

Photo Google

Vous commentez à l'aide de votre compte Google. Déconnexion /  Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion /  Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion /  Changer )

Connexion à %s